Outils pour utilisateurs

Outils du site


public:passage_de_java_6_a_java_7

Ceci est une ancienne révision du document !


Passage de Java 6 à Java 7 dans TXM

Raisons pour passer à JAva 7

Age de Java 6

  • état des versions
    • La version actuelle de Java proposé en téléchargement est 8 (plutôt récent : 2014-03-18)
      • N'est pas maintenue pour Windows XP
    • La version 7 est là depuis le 2011-07-28 (+ de 3ans ! :-o )
    • La version 6 de Java ne sera bientôt plus maintenu (du pt de vue des failles de sécurité) ou l'est déjà : trouver une confirmation
  • Du point de vue de l'OS :
    • Windows : Avec l'update automatique Java, la version actuelle est : 10.8 (pour Windows > XP)
    • Linux : aucun problème, il faudra juste changer la dépendance Debian pour s'assurer que la version 7 soit installée
    • Mac : à confirmer, mais le support de Java7 commence à partir de la version 10.7_25
  • Il faudra recompiler cqplib

SJ : d'après ce lien : http://www.oracle.com/technetwork/java/archive-139210.html, Oracle semble produire encore des mises à jour pour les versions 5 et 6 mais uniquement pour les clients sous contrat ?

Tests de JVM sur Mac OS X 10.8.5 :

  • 2 JVM sont installées :
    • 1.6 Apple
    • 1.8 Orable
  • TXM 0.7.5 : → configurée pour utiliser une JVM de Java 6 de préférence
    • Sans jre : utilise Java 6 Apple
    • jre openjdk : idem
    • jre oracle : idem
  • TXM 0.7.7 → configurée pour utiliser une JVM de Java 7 de préférence
    • Sans jre : utilise
    • jre openjdk : utilisée
    • jre oracle : lève une erreur de link

Tests de JVM sur Mac OS X 10.6.8 :

  • 1 JVM installée
    • 1.6 Apple
  • TXM 0.7.7
    • sans jre : TXM ne démarre pas non plus. C'est RCP qui lève l'erreur car il s'attend à une JVM de Java 1.7 minimum)
    • avec jre openjdk 1.7 : TXM se lance mais crash (it seems to be a JNI library error)
    • avec jre oracle : idem

Pourquoi on reste en Java 6 ?

  • Bug : le bridge AWT/SWT est cassé ne Java 7 + SWT
  • Compatibilité avec les plugins Eclipse : est-ce-que les plugin d'Eclipse 4.4 ont besoin de Java 7 ?
    • il faut retirer le bundle XXX de TXM :
  • Les failles de sécurité sont elles pertinantes pour une JVM embarquée ?
    • non parce que : les failles concernent les applets Java
    • Le portail TXM doit il utiliser Java 7 ?
public/passage_de_java_6_a_java_7.1421048585.txt.gz · Dernière modification: 2015/01/12 08:43 par matthieu.decorde@ens-lyon.fr