Outils pour utilisateurs

Outils du site


public:extensions_beta

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
public:extensions_beta [2017/01/30 21:57]
slh@ens-lyon.fr
public:extensions_beta [2019/05/21 09:18] (Version actuelle)
matthieu.decorde@ens-lyon.fr
Ligne 1: Ligne 1:
-====== Documentation des Extensions ======+======= Documentation des Extensions ​=======
  
 Cette page recense et documente les extensions de TXM ainsi que leur niveau de publication (Beta, Stable). Cette page recense et documente les extensions de TXM ainsi que leur niveau de publication (Beta, Stable).
Ligne 5: Ligne 5:
 Vous pouvez partager la documentation de vos propres extensions avec la communauté des utilisateurs de TXM dans cette page. Vous pouvez partager la documentation de vos propres extensions avec la communauté des utilisateurs de TXM dans cette page.
  
-Pour rappel, l'​installation d'une extension TXM se fait en appelant la commande "​Fichier > Ajouter une extension"​. Voir également ​la section ​du manuel TXM à ce sujet [[http://txm.sourceforge.net/​doc/​manual/​manual16.xhtml#toc53|Installer une extension dans TXM]]((attention au 25/01/2017 le manuel ​n'​est ​plus à jour : la commande n'est plus dans le menu "​Aide"​ mais dans le menu "​Fichier"​))+Pour rappel, l'​installation d'une extension TXM se fait en appelant la commande "​Fichier > Ajouter une extension"​. Voir la section [[http://textometrie.ens-lyon.fr/html/​doc/​manual/​0.7.9/​fr/​manual8.xhtml#bkmRefHeading155241964119527|Installer une extension dans TXM]] du manuel ​pour plus de détails.
  
-===== Installation =====+======= Installation ​=======
  
-==== TreeTagger installer ====+===== TreeTagger installer ​=====
  
 Cette extension installe le logiciel TreeTagger sur votre machine. Cette extension installe le logiciel TreeTagger sur votre machine.
Ligne 25: Ligne 25:
 Pour connaître le répertoire stockant les fichiers modèles où déposer les nouveaux fichiers modèle, il suffit d'​aller à la page de préférences "TXM > Avancé > TAL > TreeTagger"​ et de cliquer sur le bouton "​Ouvrir le répertoire des fichiers modèles"​. L'​explorateur de fichiers du système s'​ouvrira alors directement dans ce répertoire. Vous n'avez plus qu'à y glisser vos nouveaux fichiers modèles. Pour connaître le répertoire stockant les fichiers modèles où déposer les nouveaux fichiers modèle, il suffit d'​aller à la page de préférences "TXM > Avancé > TAL > TreeTagger"​ et de cliquer sur le bouton "​Ouvrir le répertoire des fichiers modèles"​. L'​explorateur de fichiers du système s'​ouvrira alors directement dans ce répertoire. Vous n'avez plus qu'à y glisser vos nouveaux fichiers modèles.
  
-===== Annotation =====+======= Annotation ​=======
  
-==== Annotation Analec ​====+====== URS ======
  
-L'​extension Analec permet d'​annoter les textes d'un corpus ​avec une structure d'​annotation de type Glozz et de réaliser diverses exploitations de ces annotations.+  * [[public:​documentation_extensions:​urs|Annotation ​avec un modèle Unité-Relation-Schéma (URS)]]
  
-Cette première version ​de l'​extension permet d'​annoter interactivement les unités au sein des éditions de texte de TXM, ainsi que d'​enrichir l'​annotation,​ de vérifier sa cohérence, de procéder à quelques extractions pour affichage ou décomptes à l'aide de macros TXM. L'​interface d'​annotation des unités reproduit celle du logiciel Analec, donc nous vous invitons à consulter la [[http://​www.lattice.cnrs.fr/​IMG/​pdf/​ManuelAnalec_1501.pdf|documentation d'​Analec]] pour apprendre à utiliser la barre d'​outils d'​annotation des unités (en particulier la section "​Annoter des unités"​ page 15).+======= Visualisation ​de données =======
  
-Voir le [[https://​groupes.renater.fr/​wiki/​txm-users/​public/​umr_lattice/​democrat/​tutoriel_installation_txm_analec|"​Tutoriel d'​utilisation de TXM pour manipuler des annotations Analec"​]] pour l'​installation et l'​utilisation de cette extension. +====== ​WordCloud ​======
- +
- +
-===== Visualisation de données ​===== +
- +
-==== WordCloud ​====+
 <​note>​STABLE</​note>​ <​note>​STABLE</​note>​
 L'​extension WordCloud ajoute une commande TXM qui construit une représentation graphique d'​index sous la forme d'un nuage de mots. L'​extension WordCloud ajoute une commande TXM qui construit une représentation graphique d'​index sous la forme d'un nuage de mots.
  
-=== Installation ===+==== Installation ​====
  
 Cette extension installe le package "​wordcloud"​ ainsi que toutes ses dépendances R. Plus de détails sur [[http://​cran.r-project.org/​web/​packages/​wordcloud/​index.html|la page du package wordcloud sur R-cran]]. Cette extension installe le package "​wordcloud"​ ainsi que toutes ses dépendances R. Plus de détails sur [[http://​cran.r-project.org/​web/​packages/​wordcloud/​index.html|la page du package wordcloud sur R-cran]].
  
-=== Utilisation ===+==== Utilisation ​====
  
 1) Sélectionner un corpus, un Index ou un Lexique dans la vue Corpus. 1) Sélectionner un corpus, un Index ou un Lexique dans la vue Corpus.
Ligne 61: Ligne 56:
 Note : appliquée à un corpus, la commande se basera sur un Index des mots pleins pour les langues FR et EN (en utilisant des requêtes adaptées aux modèles TreeTagger correspondants) et sur un Index total pour les autres langues. Note : appliquée à un corpus, la commande se basera sur un Index des mots pleins pour les langues FR et EN (en utilisant des requêtes adaptées aux modèles TreeTagger correspondants) et sur un Index total pour les autres langues.
  
-=== Difficultés d'​installation === +==== Difficultés d'​installation ====
  
 En cas d'​échec d'​installation automatique des packages "​RColorBrewer"​ ou "​wordcloud"​ dans R, il faut installer soi-même ces packages dans le R utilisé par TXM. En cas d'​échec d'​installation automatique des packages "​RColorBrewer"​ ou "​wordcloud"​ dans R, il faut installer soi-même ces packages dans le R utilisé par TXM.
Ligne 102: Ligne 96:
 **Pour les autres versions de R**, il faut utiliser une version du package wordcloud dont la date de publication est la plus proche possible de la date de livraison du R installé, voir [[http://​cran.r-project.org/​src/​contrib/​Archive/​wordcloud]] **Pour les autres versions de R**, il faut utiliser une version du package wordcloud dont la date de publication est la plus proche possible de la date de livraison du R installé, voir [[http://​cran.r-project.org/​src/​contrib/​Archive/​wordcloud]]
  
-===== Multimédia =====+======= Multimédia ​=======
  
-==== Media Player ====+====== Media Player ​======
  
-<​note>​STABLE</​note>​+<​note>​BETA</​note>​
  
 L'​extension "Media Player"​ permet de jouer depuis une concordance TXM un extrait de son ou de vidéo correspondant à l'​intégralité du tour de parole (<​sp>​) d'une transcription où le mot pivot d'une ligne de concordance a été prononcé. Il s'agit donc d'un retour au texte adapté aux corpus multimédia complémentaire au retour au texte classique (de la transcription). L'​extension "Media Player"​ permet de jouer depuis une concordance TXM un extrait de son ou de vidéo correspondant à l'​intégralité du tour de parole (<​sp>​) d'une transcription où le mot pivot d'une ligne de concordance a été prononcé. Il s'agit donc d'un retour au texte adapté aux corpus multimédia complémentaire au retour au texte classique (de la transcription).
  
-=== Installation ===+==== Installation ​====
  
 Installer le logiciel VLC : [[http://​www.videolan.org/​vlc|Site officiel de VLC]]. Installer le logiciel VLC : [[http://​www.videolan.org/​vlc|Site officiel de VLC]].
Ligne 116: Ligne 110:
 Attention : l'​extension ne fonctionne pas sous Linux 32bit (bug lié aux scripts Lua de VLC 32bit). Attention : l'​extension ne fonctionne pas sous Linux 32bit (bug lié aux scripts Lua de VLC 32bit).
  
-=== Utilisation ===+==== Utilisation ​====
  
-== Préparation ​du corpus ==+=== Préparation ​d'​un ​corpus ​quelconque ===
  
 Pour que le plugin fonctionne, il faut : Pour que le plugin fonctionne, il faut :
-  * A) que le corpus de transcriptions ai été importé avec le module d'​import 'XML Transcriber +CSV'​ +  * A) que le corpus de transcriptions ai été importé avec le module d'​import 'XML Transcriber + CSV' 
-  * B) que les fichiers ​d'​enregistrement audio ou vidéo ​correspondant à chaque transcription soient déposés ​dans le répertoire '​media'​ du corpus binaire+  * B) qu'à chaque transcription corresponde un fichier ​d'​enregistrement audio (par exemple au format mp3) ou vidéo ​(par exemple au format mp4) déposé ​dans le répertoire '​media'​ du corpus binaire ​avec le nom du fichier de transcription. Exemple, pour la transcription '​transcription01.trs'​ correspond le fichier audio '​transcription01.mp3'​
  
 La procédure de préparation du corpus est donc la suivante : La procédure de préparation du corpus est donc la suivante :
-  - importer le corpus (par exemple '​moncorpus'​) avec le module d'​import 'XML Transcriber +CSV'​\\ L'​import crée le dossier <DOSSIER UTILISATEUR>/​corpora/​moncorpus +  - importer le corpus (par exemple '​moncorpus'​) avec le module d'​import 'XML Transcriber +CSV'​\\ L'​import crée le dossier <DOSSIER UTILISATEUR>/​corpora/​MONCORPUS 
-  - créer un dossier '​media'​ dans le répertoire du corpus binaire (par exemple : <DOSSIER UTILISATEUR>/​TXM/​corpora/​moncorpus/media) +  - créer un dossier '​media'​ dans le répertoire du corpus binaire (par exemple : <DOSSIER UTILISATEUR>/​TXM/​corpora/​MONCORPUS/media) 
-  - copier les fichiers audio ou vidéo dans le dossier '​media'​ +  - copier les fichiers audio ou vidéo dans le dossier '​media' ​: 
-    * les fichiers audio/vidéo supportés sont : mp3, wavmp4, avi (la liste évolue selon les développements de VLC et l'​intégration dans TXM). L'​extension des fichiers média doit être en minuscule.+    * les fichiers audio peuvent être d'​extension ​: mp3, ogg et wav 
 +    * les fichiers vidéo peuvent être d'​extension : mp4, avi, mov\\ (la liste évolue selon les développements de VLC et l'​intégration dans TXM). 
 +    * l'​extension des fichiers média doit être en minuscule.
     * il doit y avoir un fichier audio ou vidéo par transcription. Par exemple, si un corpus est composé de trois transcriptions nommées '​trans1.trs',​ '​trans2.trs'​ et '​trans3.trs'​ alors il faut copier dans le répertoire '​media'​ trois fichiers audio nommés '​trans1.mp3',​ '​trans2.mp3'​ et '​trans3.mp3'​. ​     * il doit y avoir un fichier audio ou vidéo par transcription. Par exemple, si un corpus est composé de trois transcriptions nommées '​trans1.trs',​ '​trans2.trs'​ et '​trans3.trs'​ alors il faut copier dans le répertoire '​media'​ trois fichiers audio nommés '​trans1.mp3',​ '​trans2.mp3'​ et '​trans3.mp3'​. ​
  
-== Lecture de la vidéo ou de l'​audio ==+=== Corpus exemple prêt à l'​emploi === 
 + 
 +  * [[https://​sourceforge.net/​projects/​txm/​files/​corpora/​p1s8-course-transcription|P1S8 4 avril 2014]], transcription et enregistrement d'un cours de physique en Lycée (cours sur la lumière) : 
 +    * charger '​p1s8-bin.txm'​ dans TXM 
 +    * ajouter dans le répertoire '​media'​ du corpus binaire le fichier 'P1S8 30 avril 2014.mp4'​ 
 +    * ou bien le fichier 'P1S8 30 avril 2014.mp3'​ si on ne souhaite tester que l'​audio 
 + 
 +Pour des raisons de protection de la vie privée (image, voix, nom et prénom, etc.), seule la partie située entre 0h 30m 26s et 0h 31m 39s du cours est visible et audible et la transcription est entièrement anonymisée. Pour faire un retour à la vidéo utile, il faut donc faire une concordance de mots prononcés dans cet intervalle. Par exemple : 
 +  * Concordance de '​néon'​ 
 +  * faire un retour au média depuis la 6ième ligne :\\ <​code>​P1S8 30 avril 2014, P, 0:​30:​49 ​  si vous faites taper la lumière d'​un ​  ​néon ​  sur un CD vous ne verrez pas toutes les couleurs de l'</​code>​ 
 + 
 +=== Lecture de la vidéo ou de l'​audio ​===
  
 Le retour à l'​audio/​vidéo est opéré soit :  Le retour à l'​audio/​vidéo est opéré soit : 
Ligne 140: Ligne 147:
 Si le retour à l'​audio/​Vidéo ne fonctionne pas, un message de diagnostic s'​affiche dans la console de TXM. Si le retour à l'​audio/​Vidéo ne fonctionne pas, un message de diagnostic s'​affiche dans la console de TXM.
  
-L'​extension permet également de jouer un fichier vidéo ou audio directement dans TXM, indépendamment d'un corpus, avec la commande '​Fichier / Ouvrir media'​.+L'​extension permet également de jouer un fichier vidéo ou audio directement dans TXM, indépendamment d'un corpus, avec la commande '​Fichier / Ouvrir media' ​(utile pour vérifier le bon fonctionnement de VLC).
  
 **Interface du lecteur multimedia** **Interface du lecteur multimedia**
Ligne 153: Ligne 160:
   * Vol : volume de lecture   * Vol : volume de lecture
  
-=== Préférences ===+==== Préférences ​====
  
 A) Répéter la lecture : oui/non A) Répéter la lecture : oui/non
Ligne 172: Ligne 179:
 Par défaut, l'​empan est construit à partir de la propriété "​time"​ **du premier mot du contexte gauche** et **du dernier mot du contexte droit** de la ligne de concordance. C'est donc la taille du contexte de la concordance qui définit la taille de l'​empan temporel à jouer. Par défaut, l'​empan est construit à partir de la propriété "​time"​ **du premier mot du contexte gauche** et **du dernier mot du contexte droit** de la ligne de concordance. C'est donc la taille du contexte de la concordance qui définit la taille de l'​empan temporel à jouer.
  
-===== Import ​====+======= ​Éditeurs ​=======
- +
-==== Environnement SVN ==== +
- +
-<​note>​BETA</​note>​ +
- +
-=== Utilisation === +
- +
-== Créer un repository local == +
- +
-  * Ouvrir la vue "​Référentiel SVN" : à partir du menu "​Affichage > Vues > Autres",​ sélectionner "​SVN"​ puis "​Référentiel SVN" +
-  * Dans la nouvelle vue, faire clic droit et sélectionner "​Nouveau > Repository..."​ +
-  * Une boite de dialogue s'​ouvre +
-  * Indiquer le chemin local où le répository doit être créé +
-  * Bouton "​OK"​ +
- +
-== Se connecter à un repository SVN == +
-  * La première étape consiste à configurer le repository SVN +
-    * Ouvrir la vue "​Explorateur de projet : à partir du menu "​Affichage > Vues > Autres",​ sélectionner "​Général"​ puis "​Explorateur de projet"​ +
-    * Dans la vue "​Explorateur de projet",​ faire clic droit et sélectionner "​Nouveau > Projet..."​ +
-    * Dans la boite de dialogue ouverte, sélectionner "SVN > Projet depuis SVN" +
-    * Indiquer dans le champ "​URL"​ la localisation URL du repository SVN (local: file:// ou distant http://) +
-    * Bouton "​Suivant"​ +
-    * Bouton "​Terminer"​ +
-  * La fenêtre suivante sers à configurer le projet, faire "​Terminer"​ +
-    * Si le repository ne contient pas de projet, il faut le configurer **sinon** c'est fini. +
-    * une nouvelle fenêtre à du s'​ouvrir +
-    * Choisir le type de projet "​General > Projet"​ +
-    * Bouton "​Suivant"​ +
-    * Nommer le projet +
-    * Bouton "​Terminer"​ +
- +
-===== Éditeurs ​=====+
  
-==== XMLEditor ====+====== XMLEditor ​======
  
 <​note>​BETA</​note>​ <​note>​BETA</​note>​
Ligne 212: Ligne 187:
 Cette extension permet d'​éditer des fichiers XML avec aide à la lecture et à l'​écriture. Cette extension permet d'​éditer des fichiers XML avec aide à la lecture et à l'​écriture.
  
-=== Utilisation ===+==== Utilisation ​====
  
 Un fichier XML s'​ouvre à l'aide de la commande "Open XML file..."​ du menu fichier. Un fichier XML s'​ouvre à l'aide de la commande "Open XML file..."​ du menu fichier.
Ligne 218: Ligne 193:
 Documentation complète : [[http://​sourceforge.net/​projects/​txm/​files/​documentation/​Manuel%20editeur%20XML%20de%20TXM.pdf/​download]] Documentation complète : [[http://​sourceforge.net/​projects/​txm/​files/​documentation/​Manuel%20editeur%20XML%20de%20TXM.pdf/​download]]
  
-==== PracticallyMacro ====+====== PracticallyMacro ​======
  
 <​note>​BETA</​note>​ <​note>​BETA</​note>​
Ligne 224: Ligne 199:
 Cette extension permet d'​enregistrer une séquence d'​appuis sur les touches du clavier et de la souris et de la rejouer. Cette extension permet d'​enregistrer une séquence d'​appuis sur les touches du clavier et de la souris et de la rejouer.
  
-=== Utilisation ===+==== Utilisation ​====
  
 Dans un éditeur de texte de TXM. Dans un éditeur de texte de TXM.
Ligne 239: Ligne 214:
     * ou avec le raccourcis clavier Ctrl-Alt-P     * ou avec le raccourcis clavier Ctrl-Alt-P
  
-=== Paramètres ===+==== Paramètres ​====
  
 Aucun Aucun
  
-===== Préparation et analyse de corpus paléographiques =====+======= Préparation et analyse de corpus paléographiques ​=======
  
-==== Extension Oriflamms ====+====== Extension Oriflamms ​======
  
 Cette extension a été développée dans le cadre du projet ANR Oriflamms [[http://​oriflamms.hypotheses.org]]. Elle permet de préparer les corpus de transcriptions de manuscrits respectant le format spécifié au traitement par le logiciel Oriflamms (alignement du texte à l'​image,​ classification des formes de caractères) et à l'​import dans TXM dans le cadre du module XTZ+CSV. Elle inclut également plusieurs commandes utile à l'​analyse paléographique. Cette extension a été développée dans le cadre du projet ANR Oriflamms [[http://​oriflamms.hypotheses.org]]. Elle permet de préparer les corpus de transcriptions de manuscrits respectant le format spécifié au traitement par le logiciel Oriflamms (alignement du texte à l'​image,​ classification des formes de caractères) et à l'​import dans TXM dans le cadre du module XTZ+CSV. Elle inclut également plusieurs commandes utile à l'​analyse paléographique.
  
public/extensions_beta.1485809854.txt.gz · Dernière modification: 2017/01/30 21:57 par slh@ens-lyon.fr