Différences

Cette page vous donne les différences entre la révision choisie et la version actuelle de la page.

public:extensions_beta [2017/12/04 08:47]
slh@ens-lyon.fr
public:extensions_beta [2018/10/18 12:16] (version actuelle)
slh@ens-lyon.fr
Ligne 5: Ligne 5:
Vous pouvez partager la documentation de vos propres extensions avec la communauté des utilisateurs de TXM dans cette page. Vous pouvez partager la documentation de vos propres extensions avec la communauté des utilisateurs de TXM dans cette page.
-Pour rappel, l'installation d'une extension TXM se fait en appelant la commande "Fichier > Ajouter une extension". Voir également la section du manuel TXM à ce sujet [[http://txm.sourceforge.net/doc/manual/manual16.xhtml#toc53|4 Installer une extension dans TXM]]((attention au 25/01/2017 le manuel n'est plus à jour : la commande n'est plus dans le menu "Aide" mais dans le menu "Fichier"))+Pour rappel, l'installation d'une extension TXM se fait en appelant la commande "Fichier > Ajouter une extension". Voir la section [[http://textometrie.ens-lyon.fr/html/doc/manual/0.7.9/fr/manual8.xhtml#bkmRefHeading155241964119527|Installer une extension dans TXM]] du manuel pour plus de détails.
===== Installation ===== ===== Installation =====
Ligne 27: Ligne 27:
===== Annotation ===== ===== Annotation =====
-==== Annotation Analec ====+==== Annotation URS ====
-Voir le [[https://groupes.renater.fr/wiki/txm-users/public/umr_lattice/democrat/public/manuel_utilisation_extension_analec|Manuel d'utilisation de l'extension Analec de TXM]] pour l'installation et l'utilisation de cette extension.+Voir la section [[http://textometrie.ens-lyon.fr/html/doc/manual/0.7.9/fr/manual53.xhtml#toc285|Annotation avec un modèle Unité-Relation-Schéma (URS) au fil du texte]] du manuel de TXM pour l'installation et l'utilisation de cette extension.
Ligne 102: Ligne 102:
==== Media Player ==== ==== Media Player ====
-<note>STABLE</note>+<note>BETA</note>
L'extension "Media Player" permet de jouer depuis une concordance TXM un extrait de son ou de vidéo correspondant à l'intégralité du tour de parole (<sp>) d'une transcription où le mot pivot d'une ligne de concordance a été prononcé. Il s'agit donc d'un retour au texte adapté aux corpus multimédia complémentaire au retour au texte classique (de la transcription). L'extension "Media Player" permet de jouer depuis une concordance TXM un extrait de son ou de vidéo correspondant à l'intégralité du tour de parole (<sp>) d'une transcription où le mot pivot d'une ligne de concordance a été prononcé. Il s'agit donc d'un retour au texte adapté aux corpus multimédia complémentaire au retour au texte classique (de la transcription).
Ligne 114: Ligne 114:
=== Utilisation === === Utilisation ===
-== Préparation du corpus ==+== Préparation d'un corpus quelconque ==
Pour que le plugin fonctionne, il faut : Pour que le plugin fonctionne, il faut :
Ligne 128: Ligne 128:
    * l'extension des fichiers média doit être en minuscule.     * l'extension des fichiers média doit être en minuscule.
    * il doit y avoir un fichier audio ou vidéo par transcription. Par exemple, si un corpus est composé de trois transcriptions nommées 'trans1.trs', 'trans2.trs' et 'trans3.trs' alors il faut copier dans le répertoire 'media' trois fichiers audio nommés 'trans1.mp3', 'trans2.mp3' et 'trans3.mp3'.     * il doit y avoir un fichier audio ou vidéo par transcription. Par exemple, si un corpus est composé de trois transcriptions nommées 'trans1.trs', 'trans2.trs' et 'trans3.trs' alors il faut copier dans le répertoire 'media' trois fichiers audio nommés 'trans1.mp3', 'trans2.mp3' et 'trans3.mp3'.
 +
 +== Corpus exemple prêt à l'emploi ==
 +
 +  * [[https://sourceforge.net/projects/txm/files/corpora/p1s8-course-transcription|P1S8 4 avril 2014]], transcription et enregistrement d'un cours de physique en Lycée (cours sur la lumière) :
 +    * charger 'p1s8-bin.txm' dans TXM
 +    * ajouter dans le répertoire 'media' du corpus binaire le fichier 'P1S8 30 avril 2014.mp4'
 +    * ou bien le fichier 'P1S8 30 avril 2014.mp3' si on ne souhaite tester que l'audio
 +
 +Pour des raisons de protection de la vie privée (image, voix, nom et prénom, etc.), seule la partie située entre 0h 30m 26s et 0h 31m 39s du cours est visible et audible et la transcription est entièrement anonymisée. Pour faire un retour à la vidéo utile, il faut donc faire une concordance de mots prononcés dans cet intervalle. Par exemple :
 +  * Concordance de 'néon'
 +  * faire un retour au média depuis la 6ième ligne :\\ <code>P1S8 30 avril 2014, P, 0:30:49   si vous faites taper la lumière d'un   néon   sur un CD vous ne verrez pas toutes les couleurs de l'</code>
== Lecture de la vidéo ou de l'audio == == Lecture de la vidéo ou de l'audio ==
Ligne 169: Ligne 180:
Par défaut, l'empan est construit à partir de la propriété "time" **du premier mot du contexte gauche** et **du dernier mot du contexte droit** de la ligne de concordance. C'est donc la taille du contexte de la concordance qui définit la taille de l'empan temporel à jouer. Par défaut, l'empan est construit à partir de la propriété "time" **du premier mot du contexte gauche** et **du dernier mot du contexte droit** de la ligne de concordance. C'est donc la taille du contexte de la concordance qui définit la taille de l'empan temporel à jouer.
- 
-===== Import ===== 
- 
-==== Environnement SVN ==== 
- 
-<note>BETA</note> 
- 
-=== Utilisation === 
- 
-== Créer un repository local == 
- 
-  * Ouvrir la vue "Référentiel SVN" : à partir du menu "Affichage > Vues > Autres", sélectionner "SVN" puis "Référentiel SVN" 
-  * Dans la nouvelle vue, faire clic droit et sélectionner "Nouveau > Repository..." 
-  * Une boite de dialogue s'ouvre 
-  * Indiquer le chemin local où le répository doit être créé 
-  * Bouton "OK" 
- 
-== Se connecter à un repository SVN == 
-  * La première étape consiste à configurer le repository SVN 
-    * Ouvrir la vue "Explorateur de projet : à partir du menu "Affichage > Vues > Autres", sélectionner "Général" puis "Explorateur de projet" 
-    * Dans la vue "Explorateur de projet", faire clic droit et sélectionner "Nouveau > Projet..." 
-    * Dans la boite de dialogue ouverte, sélectionner "SVN > Projet depuis SVN" 
-    * Indiquer dans le champ "URL" la localisation URL du repository SVN (local: file:// ou distant http://) 
-    * Bouton "Suivant" 
-    * Bouton "Terminer" 
-  * La fenêtre suivante sers à configurer le projet, faire "Terminer" 
-    * Si le repository ne contient pas de projet, il faut le configurer **sinon** c'est fini. 
-    * une nouvelle fenêtre à du s'ouvrir 
-    * Choisir le type de projet "General > Projet" 
-    * Bouton "Suivant" 
-    * Nommer le projet 
-    * Bouton "Terminer" 
===== Éditeurs ===== ===== Éditeurs =====
public/extensions_beta.1512373677.txt.gz · Dernière modification: 2017/12/04 08:47 par slh@ens-lyon.fr