Mise en ligne du corpus Epistemon avec TXM

(projet BSN Corporem)

Import

Hébergement

  • Phase 1 : prototype privé à Tours (2015-02-15 - 2015-02-28)
  • Phase 2 : prototype à Huma-Num
  • Phase 3 : mise en production à Huma-Num

Organisation

  • Des réunions mensuelles par Skype ou en personne sont prévues entre LB et AL
  • Réunion du 2015-01-23
  • Prochaine résuion vers 2015-02-23

Retours concernant l'administration d'un portail TXM

Mail de LB (2015-06-11 16:00)

Je vous fais parvenir quelques retours concernant quelques petits bugs / questionnements / ou encore problèmes relevés jusqu'à aujourd'hui. Le cadre de ma mission est de paramétrer un portail TXM adapté au programme de recherches BVH, pour fournir à nos lecteurs, utilisateurs et/ou chercheurs des outils quantitatifs sur notre corpus EPISTEMON (une centaine de textes de la Renaissance, littéraires, en XML-TEI).

Formulaire d'inscription

Comment est générée la page ? Comment puis-je paramétrer une adresse vers laquelle le formulaire sera envoyé ? Etc… Je ne crois pas avoir vu ça dans la doc admin.

Au pire, si trop complexe, serait-il possible de couper carrément la fonctionnalité, pour ne laisser que le bouton “se connecter”. Cette dernière solution m'arrangerait beaucoup plus sachant que nous ne souhaitons que quelques utilisateurs BVH référencés (l'admin leur créera des accès), les autres peuvent être anonymes.

[SH: créer un ticket DOC “Documenter comment désactiver la possiblité d'inscription”.]

Sous-corpus impossible à supprimer

En réimportant mon corpus Epistemon, qui possédait un sous-corpus Rabelais sur la plateforme à l'origine (issu de mes tests), le sous-corpus en question n'a pas disparu, mais surtout il est impossible à supprimer à présent. J'imagine que la plateforme croit encore que le sous-corpus existe, mais quand je souhaite le supprimer, j'ai un message d'erreur.

[SH: créer un ticket GWT “Pouvoir supprimer des sous-corpus d'un corpus supprimé ou ré-importé depuis l'interface d'administration”.]

Procédure d'import

Je pense que ma procédure d'import n'est pas au point. Actuellement, si je veux réimporter mon corpus, je suis les étapes suivantes :

  • 1/ Renommer ancien binaire BVHEPISTEMON sur le serveur (il devient “bvhepistemon2” je n'arrive pas à le supprimer directement, certains fichiers restent systématiquement. Il faut couper la plateforme pour une mise à jour de ce type ?)
  • 2/ Transférer le nouveau binaire sur le serveur distant
  • 3/ Renommer le nouveau binaire (devient “bvhepistemon”)
  • 4/ Charger le nouveau binaire
  • 5/ Supprimer l'ancien binaire (là je peux le supprimer, vu que la plateforme ne l'utilise plus j'imagine)

Ce process un peu limite découle du fait que je ne peux pas supprimer le corpus depuis l'interface Admin, ce qui serait beaucoup plus simple.

[SH: créer un ticket GWT “Pouvoir supprimer un corpus depuis l'interface d'administration”.]

Problème d'état 'En maintenance' du serveur

Il m'envoie le message :

Fail : 500 Erreur Interne de Servlet The call failed on the server; see server log for details

Pour info, mes corpus se trouvent sur C:\Users\NOMUSER\TXM\corpora\ Pas dans le dossier corpora de .TXMWEB.

Message “TXM is closing…”

J'ai testé la procédure de maintenance. Je suis sortie de la maintenance mais le message réapparaît régulièrement. Je ne saurai vous dire au bout de combien de temps, je n'ai pas minuté, mais il disparaît quand je recharge la page, puis réapparaît systématiquement.

[SH: créer un ticket GWT ”'Maintenance mode' is not closed properly”.]

[SH: créer un ticket GWT “Re-phrase message 'TXM is closing…' by 'TXM is shutting down…'”.]

Mail de LB (2015-07-10 10:44)

Je viens de voir cette erreur sur mon portail, qui se portait bien jusqu'alors.

Après consultation des logs de Tomcat, j'ai ce chemin très étrange :

Config file path C:\Windows\system32\config\systemprofile\.TXMWEB\txm\txmweb.conf
[TxmConfig.start] C:\Windows\system32\config\systemprofile\.TXMWEB\txm\txmweb.conf not found.
[TxmConfig.getProperty] portal_name was not found in txmweb.conf, please fix it.

Mon dossier .TXMWEB est dans C:\, là où il s'est toujours trouvé. Et surtout là où justement j'ai dû le placer au tout premier lancement du portail pour que tout s'initialise correctement.

Avez-vous une idée de ce qui aurait pu lui faire changer son comportement au lancement ?

[SH: créer un ticket GWT “Au lancement du portail, afficher : 'Utilisation du fichier de configuration C:…/txmweb.conf dont le chemin est défini dans le fichier C:…/XXX.'”.]



Retour à la liste des projets.

public/mise_en_ligne_du_corpus_bvh_avec_txm.txt · Dernière modification: 2015/10/07 11:39 par slh@ens-lyon.fr