Outils pour utilisateurs

Outils du site


public:retours_de_bugs_logiciel:slh_test_0.5beta_2010_10_12

12/10/2010 12:41

  1. il faut que le nom de l'archive téléchargée et celui du répertoire d'extraction soient les mêmes OK
  2. il faut que la doc (INSTALL) soit synchrone avec cela OK
  3. si install a l'extension '.bash' alors il faut que 'uninstall' ai la même extension OK
  4. il faut que la doc soit synchrone avec ces extensions OK
  5. message du script d'install :

“TXM install: This script will now create the 'TXM' directory in the install directory, create a link to the TXM binary and install R if it is not already installed.” Il faut ajouter le chemin réel du répertoire d'installation désigné (entre parenthèses) après le 'install directory'. OK

  1. bug : si le répertoire d'install est relatif, par exemple '..'

l'install ne fonctionne pas correctement (par exemple le lien vers le binaire est mauvais, pire le 'install.prefs' contient des chemins inexacts, etc.) - correction : il faut appliquer 'readlink -f …' sur $1 et $2 avant de les utiliser (pour être sûr qu'on manipule bien des chemins complets qui fonctionneront dans install.prefs (entre autres) OK

12/10/2010 12:52

  1. quand une concordance ne trouve pas son édition pour faire un retour au texte (pour une raison indéterminée), il faut un message d'erreur qui le dise (console+status bar) OK
  2. Index: le message 'Terminé : 42 lignes' gagnerait à être remplacé par '42 résultats.'. Par contre, quand il y a des seuils (par exemple en fréquence) il ne faut pas afficher '42 résultats' parce qu'il y en a moins. OK
  3. Hypertexte : le calcul direct de la concordance à partir du vocabulaire ne fonctionne pas OK

18/10/2010 3:08

  1. menu démarrer : la mention habituelle de Windows “un nouveau logiciel a été installé…” n'apparait plus
  2. message job running script : ajouter l'argument du loader dans le titre (le répertoire source) OK
  3. message HyperbaseLoader : “Aborting “ANNOTATE: Modelfile path is wrong: C:\…” → “Skipping ANNOTATE: Incorrect modelfile path: C:\..”OK
  4. tokenizer :
    1. prévoir une version non XML-aware pour avoir des performances acceptables au moins pour le texte brut (le plus fréquent pendant encore un bon bout de temps) OK + faire une réunion
    2. EOS incorrect sur le point : ” J. Rey Debove“, ”(78, p. 226)“, etc.
    3. bad chars dans Auteurs : [>, †, #, ˜, ¯, ®, ­, }, ±, {, ´, ¥, ¼, ½] à gérer correctement OK - 12 '%' seuls, à coller au nombre (entier) qui précède [word=”.*“] [word=”%“]
    4. 15141 '(' alors que 15610 ')', pourquoi une telle différence ? Réponse : c'est à cause des '.' qui ont pris des '('
    5. '.”.' –> 3 fois sur 4 = '…“.' –> '…' + '”…' [word=“.\”.“] - '.).' curieux - ', etc.).' → ',' 'etc.' ')' '.' - 1789Ce, 1789L', 1796Prédication ??? - -/<Toujours ??? - .(A. –> '.' '(' 'A.' pour toutes les majs (voir les règles des points de Nantes)
    6. '⇔Difficulté' –> '⇔' 'Difficulté'
    7. '<linguistique' : où est le '>' ? Réponse il a été ignoré en tant que 'bad char' cf ci-dessus
    8. '>activité' –> '>' 'activité' ???
    9. '1Ligne' –> '1' 'Ligne' valable pour tous les nombres (plusieurs chiffres) - '85]Dans' –> '85' ']' 'Dans' - 'A1=NON' –> 'A1' '=' 'NON' - “abattre'” → “abattre” ”'“ - ABMêmeAutre ??? Réponse : se trouve dans le texte source Siblot.xml on ne fait rien
    10. 'accessible(11)' –> 'accessible' '(' '11' ')'
    11. 'la/une/cette' –> 'la' '/' 'une' '/' 'cette'
  5. Edition : impossible sur Auteurs –> CPU 100% utilisé par cqpserver, temps indéterminé
  6. Lexique
    1. ponctuations à filtrer ? (liste de caractères ou séquence '…', clasees Unicode, pos)
    2. mots outils à filtrer ?
    3. lors de l'exportation, un éditeur s'ouvre (on ne l'a pas demandé –> à retirer) et l'encodage est affiché en CP1252 alors que c'est de l'UTF-8 (sous Windows)
    4. pouvoir 'Copier' les entrées sélectionnées, en plus de 'Envoyer vers …'
    5. message console :

“Calcul du lexique du corpus AUTEURS avec la propriété word” –> “Lexique de la propriété <word> dans le corpus AUTEURS” OK

  1. Index
    1. dans le titre de la boite de dialogue du job –> ajouter les paramètres (au moins l'expression CQP)
    2. requête : [] [”%“] –> erreur
    3. requête : [] [“\%”] –> erreur
    4. requête : [word=”.*“] [word=”.*%“] –> OK
    5. Ajouter “Copier” en plus de “Envoyer vers”. Le copier peut séparer les entrées par un séparateur (comme ', ' par défaut)
    6. Quand on va à la page suivante, il faut remettre la scrollbar en haut
    7. Attention quand on change la taille de la page dans l'éditeur –> il faut que la navigation vers l'AVANT en tienne compte
    8. A la fin d'un tri, il faut un message status bar 'Tri effectué'. En fait pour tout calcul lourd il faut un job et un message status bar qui conclutOK
    9. message console :

“Calcul de l'index de AUTEURS. Requête : [] [”%”] et propriété : [word]“ –> “Index de <[] [”%”]> pour la propriété <word>|les propriétés <X/Y>| dans le corpus AUTEURS.

  1. message console : 'Query mode' OK
  2. message : “Erreur lors du calculorg.textometrie.searchengine.cqp.clientExceptions.CqiClientException…” –> “Erreur lors du calcul|en rouge| : org.textometrie.searchengine.cqp.clientExceptions.CqiClientException”
  3. message : “Terminé : 0 résultats” –> “Aucune occurrence.”
  4. Concordances
  5. il faut un caractère délimiteur entre les positions des occurrences d'une expression CQP dans la colonne pivot (l'espace par défaut) 'A.).' –> 'A .).' dans le pivot
  6. Ajouter 'Envoyer vers l'Index' (le pivot situé sous la souris) OK
  7. message console :

“Calcul d'une concordance dans AUTEURS avec : [word=“I”] [word=”.).“]” –> “Concordance de <[word=“I”] [word=”.).“]> dans le corpus AUTEURS

  1. message status bar 'Terminé : 1 occurrences' → 'Une occurrence.' OK
  2. Informations
  3. faut il vraiment que le fichier HTML de résultats s'appelle

'Infos_class org.textometrie.searchengine.cqp.corpus.MainCorpusAUTEURS.html' –> 'AUTEURS-infos.html' OK

public/retours_de_bugs_logiciel/slh_test_0.5beta_2010_10_12.txt · Dernière modification: 2010/12/21 10:01 par matthieu.decorde@ens-lyon.fr