Outils pour utilisateurs

Outils du site


public:retours_de_bugs_logiciel:txm_0.6beta2_archives

Table lexicale

  • MD (2012-03-27) : Lors de la fusion de ligne de la table lexicale, si il ne reste qu'une seule ligne dans la table, R change le type de l'objet R (le nom de la ligne est perdu, ce qui provoque l'erreur java)
    • MD (2012-03-27) : OK

Spécificités

  • MD (2012-03-28) : Le calcul des spécificités d'un sous-corpus par rapport à son corpus parent utilise toujours la propriété “word”, peut importe celle sélectionnée dans la fenêtre de paramétrage
    • MD (2012-03-30) : OK (corrigé entre temps)

Concordances

  • SH (2012-03-17) : Le tri des références (alphabétique) ne respecte pas l'encodage (caractères accentués français mal triés)
    • MD (2012-04-04) : OK (A présent, le comparator utilise un collator avec la langue du corpus)

Binary corpus

  • MD (2012-03-30) : chargement impossible si la racine de l'archive est “nomducorpus/data/” au lieu de “nomducorpus/
    • MD (2012-03-30) : OK
Extracting /Users/Travail/Documents/workspace/bvhepistemon-bin.zip in /Users/Travail/TXM/corpora
Scanning for corpora...
ERROR: The input directory is not in the TXM corpus binary format:  /Users/Travail/TXM/corpora/bvhepistemon/**data**

Imports

  • SH (2012-03-09) : Import XML/w+CSV, messages d'erreur et stacktrace dans la console à la sélection du répertoire source :
    • MD (2012-02-13) : OK
The source directory does not contains import.xml
Load import parameters from file: /home/sheiden/enslyon_projets/Textométrie/SpUV/catpol/catpol/import.xml
java.lang.NullPointerException
  at org.txm.rcpapplication.editors.imports.CorpusPage.loadParams(CorpusPage.java:1370)
  at org.txm.rcpapplication.editors.imports.CorpusPage.selectSourceDir(CorpusPage.java:1445)
  at org.txm.rcpapplication.editors.imports.CorpusPage$34.linkActivated(CorpusPage.java:1178)
  at org.eclipse.ui.forms.widgets.AbstractHyperlink.handleActivate(AbstractHyperlink.java:233)
  at org.eclipse.ui.forms.widgets.AbstractHyperlink.handleMouseUp(AbstractHyperlink.java:327)
  • SH (2012-03-09) : Import XML/w+CSV, Boite de dialogue 'Exécution du script…' : message 'APPLY XSL' → 'APPLYING XSL' (de quelle XSL s'agit il d'ailleurs ?)
    • MD (2012-02-13) : OK
  • SH (2012-03-09) : Import XML/w+CSV, message console pendant l'import : message 'Try to read import properties file: /home/sheiden/enslyon_projets/Textométrie/SpUV/catpol/catpol/import.properties' → 'Trying to read import properties file: /home/sheiden/enslyon_projets/Textométrie/SpUV/catpol/catpol/import.properties' (est-ce vraiment nécessaire d'avoir ce message ?)
    • MD (2012-02-13) : OK
  • SH (2012-03-09) : Import XML/w+CSV, messages console pendant l'import : 'Files processed…'/'Getting structural attributes…' quand il y a trop de noms de fichiers leur afficage devient inefficace. Il faudrait choisir des noms de fichiers à afficher (modulo) pour n'afficher au final que 10 noms de fichiers en tout, en les séparant par des '…'.
    • MD (2012-02-13) : OK (même bug que SH du 2012-03-09)
  • SH (2012-03-09) : Import XML/w+CSV, message plus loin 'Try to read metadatas from…' → 'Trying to read metadata from…'
    • MD (2012-04-05) : OK
  • SJ (2012-03-15) : Interface, certaines entrées du menu 'File\Import\XML xxx' semblent pointer vers les mauvaises fonctionnalités, ex : 'XML-TEI TXM' pointe vers les paramètres de 'XML-PP5'. Je ne sais pas si c'est juste une erreur de titre ou si c'est tout l'onglet qui n'est pas le bon, en tout cas je n'ai pas réussi à importer des fichiers XML-TEI à partir de l'onglet d'import qui s'ouvre en cliquant sur 'File\Import\XML-TEI TXM'
  • LB (2012-03-16) : Import TXT+CSV, freeze de la plateforme lors de la sélection de la langue via l'ascenseur (ça passe si on la tape directement)
    • MD (2012-03-16) : OK
  • RA (2012-03-23) : l'import ne fonctionne pas si le nom du corpus n'est pas en majuscules, mais le problème n'apparaît qu'à la fin de toutes les étapes : “org.txm.searchengine.cqp.clientExceptions.InvalidCqpIdException: Vulgate n'est pas un id cqp valide. Il doit être en majuscule.” La doc précise seulement : “Ce nom ne doit pas contenir de caractères spéciaux ni d'espace.” et, dans TXM 0.5, le nom était transformé quand il n'était pas en majuscules.
    • MD (2012-03-23) : OK (Avant la sauvegarde le nom entrée sera automatiquement passer en MAJ et les caractères spéciaux retirés)
  • RA (2012-03-30) : Import XML/w+CSV : la première tentative d'import d'un corpus (sans fichier import.xml dans le dossier) ne fonctionne pas. Toutes les étapes s'affichent dans la console normalement, mais l'import se termine par : “Error: skipping the loading of corpus: VULGATE”. Si, après cette première tentative, je tente à nouveau de charger le même corpus, en lui donnant le même nom, ça marche parfaitement.
    • MD (2012-04-03) : OK (c'était un bug de rafraichissement des paramètres d'import)

Interface

  • SJ (2012-03-15) : 'Corpus\Delete' via barre de menu ou menu contextuel, le corpus semble supprimé de CWB mais l'entrée reste dans la vue 'Corpus', problème de refresh du composant ? D'autre part, le répertoire du corpus dans TXMHOME n'est pas supprimé, est-ce bien le comportement voulu ?
    • MD (2012-03-16) : OK, c'était un problème de rafraichissement. Et dorénavent le binaire est supprimé
  • SJ (2012-03-15) : Plantage de FactoMineR lors des AFC sur des tables hors limites (ex : moins de 3 colonnes ou moins de 3 lignes). Ne pas lancer d'AFC si la table est hors limite ?
    • SJ (2012-03-15) : Après vérifications, il y a bien un message d'erreur pour les tables hors limites sur les colonnes mais pas sur les lignes. D'ailleurs, pourquoi la limite est fixée à 4 parties, il me semble que ça n'est pas problématique de calculer des AFC à partir de tables de dimensions 3*3.
    • MD (2012-03-16) : OK (j'ai rajouté le test pour les lignes)
  • SJ (2012-03-16) : 'Open edition' sur une partition ouvre le dialogue de sélection de partie mais n'aboutit à rien ensuite (ni en cliquant sur une partie, ni en tapant son nom).
    • MD (2012-03-16) : OK (problème corrigé, les sous-corpus avaient aussi ce problème)

Mac OS X

  • JCD(2012-03-11) : Impossible d'installer sur MacOSX (10.6). Pblme de script d'installation ?
    • MD (2012-03-14) : OK (c'était un problème de script de pré-install)
  • SJ (2012-03-15) : Win XP 32, Erreur au premier lancement de TXM si TXMHOME existe déjà. La copie des fichiers depuis TXMINSTALL échoue après avoir choisi 'Yes' dans le dialogue de création de backup ('Moving previous corpus into: C:\Documents and Settings\s\TXM\TXM-corpus-backup Failed to copy TXM files from TXMINSTALL DIR to TXMHOME : java.lang.NullPointerException').
    • MD (2012-04-04) : le message d'erreur n'est pas bon, je l'ai corrigé), je n'arrive pas à reproduire ce bug par contre)
    • SJ (2012-03-22) : Après réinstallation de TXM l'erreur venait probablement du fait que mon répertoire TXMHOME était issu d'une version ancienne de TXM et que la structure du répertoire a sans doute changé entre cette ancienne version et la 0.6. En tout cas cela fonctionne bien si le TXMHOME déjà existant est issu de la 0.6b2.
public/retours_de_bugs_logiciel/txm_0.6beta2_archives.txt · Dernière modification: 2014/07/31 15:49 par matthieu.decorde@ens-lyon.fr