Retours TXM 0.7.1 beta1

Cette page contient seulement les retours de problèmes de TXM 0.7.1 beta1. Pour les demandes de fonctionnalités, c'est ici que ça se passe : Demandes de fonctionnalités

Archive des bugs TXM 0.7.1beta1

Format des retours

  • initiales du testeur (date) : description du problème
    • Exemple

BP (2011-06-28) : le formulaire…

  • initiales (date), réponse (“OK”, “à retester”…
  • suite du dialogue éventuelle
  • utiliser la balise <quote> pour les citations

Participants

  • Lauranne Bertrand : LB
  • Julien Bonneau : JB
  • Gabriele Brandolini : GB
  • Matthieu Decorde : MD
  • Jean-Claude Deroubaix : JCD
  • Frédéric Erlos : FE
  • Alexei Lavrentiev : AL
  • Charles Minc : CLM
  • Pierre Ratinaud : PR

Retours généraux

  • MD (2013-03-28) : pas de message d'erreur affiché lorsque qu'une expression CQP est mal formée (le serveur cqi mémoire ne lève pas d'exception)
    • MD (2013-07-08) : OK
  • MD (2013-04-19) : La fonction Description crash TXM avec le corpus DBP sur Windows
  • MD (2013-04-19) : Import : Windows : des fichiers ouverts empêchent de réimporter un corpus
    • MD (2013-07-08) : OK
  • MD (2013-04-19) : Le corpus Fleur ne se charge pas
    • MD (2013-04-29) : OK
  • MD (2013-04-19) : Vue Interne : renommer le bouton en “Refresh”
    • MD (2013-04-29) : OK
  • MD (2013-04-19) : R script : bug si la ligne contient un ”{” par exemple : “if (…) {”
  • MD (2013-04-19) : Setup : l'install Mac 10.5 ne fonctionne plus (les fichiers sont copiés au mauvais endroit)
    • MD (2013-07-08) : OK n'est plus maintenu
  • MD (2013-04-19) : Import : Vérifier si les fichiers metadata.csv.xml sont bien créés dans le répertoire binaire et pas celui des sources
    • MD (2013-04-29) : OK
  • MD (2013-04-22) : Import : TXT+CSV : modifier le message ”… no XML files found …” quand il s'agit d'une erreur de syntaxe XML
  • FE (2013-04-27) : Le quadrillage de la table lexicale n'est plus affiché lorsque les spécificités sont calculées.
    • MD (2013-04-29) : OK

Mac OS X

  • JCD (17-04-2013) : Dans cette version à la différence des versions précédentes, la commande exportation des résultats de l'AFC ne sauvegarde plus le graphique, mais un fichier de résultats numériques bruts. Il n'y a donc plus moyens de récupérer le graphique. (Mac OS 10.6.8, 64 bits)
    • MD (2013-04-29) : OK Il y avait des entrées de menu manquantes

Windows

  • FE (2013-03-27) : J'utilise une machine portable W7 64bits. L'installation de TXM 0.7.1beta1 semble se dérouler correctement. En revanche je ne peux pas aller beaucoup plus loin. J'ai vu qu'un post avait été fait pour la version 0.7 à propos d'une machine virtuelle W7 32 bits, mais il n'y avait pas de réponse. L'utilisation des différentes fonctions appliquées à un corpus (DISCOURS ou GRAAL) donnent le même message : Could not open the editor: An exception was thrown during initialization.

La vue détaillée du message d'erreur après une demande de concordances :

 java.lang.NullPointerException
 	at org.txm.searchengine.cqp.corpus.MainCorpus.getProperties(MainCorpus.java:236)
 	at org.txm.searchengine.cqp.corpus.Corpus.getOrderedProperties(Corpus.java:1099) 
 	at org.txm.rcpapplication.editors.concordances.ConcordancesEditor.init(ConcordancesEditor.java:344)
 	at org.eclipse.ui.internal.EditorManager.createSite(EditorManager.java:828) (...)

  • AL (2013-04-15) : [Win32XP] Le changement de langue de l'interface provoque l'arrêt de TXM. Il faut arrêter RServe avant de relancer TXM. C'est un vieux bug de 0.7 béta qui resurgit !
    • MD (2013-07-04) : OK
  • AL (2013-04-15) : Lorsque je supprime un corpus XXX et puis le réimporte, j'ai l'avertissement “Le corpus XXX existe déjà…”. Cela veut dire que la suppression du corpus n'aboutit pas complètement.
    • MD (2013-07-04) : OK
  • AL (2013-04-15) : Impossible de lancer le moteur de recherche en mode réseau :

Démarrage...
Moteur de recherche lancé...** Échec de la connexion au moteur de recherche : 
- mauvais login/mot de passe/nom de machine/port :anonymous localhost 4877
- ou le moteur de recherche n'a pas été lancé avec la ligne de commande : C:\Program Files\TXM\cwb\bin\cqpserver.exe -I C:\Program Files\TXM\cwb\cqpserver.init -r C:\Documents and Settings\alavrent\TXM/registry -b 1000000 -d OFF -P 4877
Echec de la reconnexion auserveur : java.net.SocketException: Connection reset by peer: socket write error

  • résultat de la commande de test sous invité de commande windows :

C:\Documents and Settings\alavrent>"C:\Program Files\TXM\cwb\bin\cqpserver.exe" -I "C:\Program Files\TXM\cwb\cqpserver.init" -r "C:\Documents and Settings\alavrent\TXM\registry" -b 1000000 -d OFF -P 4877
Parse options for app mode 3
** CQPserver v3.4.1
** implementing version 0.1 of the CQi

^C

Import

  • JB [2013-04-18] J'ai installé le nouveau TXM sur mon ordi [Windows XP], mais j'ai toujours les mêmes bugs pour la gestion des corpus [import].
public/retours_de_bugs_logiciel/txm_0.7.1beta1.txt · Dernière modification: 2013/07/08 09:16 par matthieu.decorde@ens-lyon.fr