Outils pour utilisateurs

Outils du site


public:upr_irht_oriflamms:recette_v1

Recette de l'étape 1 du développement Oriflamms dans TXM (obsolète)

Installation de TXM

  • Installer la mise à jour TXM 0.7.8 Alpha Oriflamms :
    • télécharger l'archive https://goo.gl/3gVsgt
    • décompresser l'archive
    • dans TXM, utiliser le menu “Fichier / Ajouter une extension tierce”
    • Cliquer sur Ajouter…
      • Cliquer sur Local
      • Sélectionner le dossier “repository” créé lors de la décompression de l'archive
      • Cliquer sur OK
    • Décocher la case “Regrouper les éléments par catégorie”
    • Cliquer sur le bouton “Sélectionner tout”
    • Cliquer sur le bouton “Terminer” et suivre les instructions de l'assistant
  • Installer le paquet de macros Oriflamms
    • télécharger l'archive https://goo.gl/219Vqh
    • décompresser l'archive
    • copier le dossier “oriflamms” dans $USERDIR/TXM/scripts/macro/org/txm/macro

Récupération des corpus à utiliser pour la recette

Création d'un projet Oriflamms

  • Dans TXM, ouvrir la Vue Macro
    • Menu Affichage –> Vues –> Macro
    • Un onglet Macro s'ouvre au-dessous de la liste des corpus
  • Si aucune macro ne s'affiche dans l'onglet, cliquer sur le bouton “Rafraichir”
  • Dans l'onglet, double-cliquer sur “oriflamms”, puis “prepare”, puis sur la macro “TEI2Project” pour lancer son exécution
    • Renseigner ses paramètres pour le corpus “mss-dates” :
      • xmlFile : indiquer le document source mss-dates.xml
      • xslFile : indiquer la feuille XSLT de pré-traitement [userDir]/TXM/scripts/macro/org/txm/macro/oriflamms/prepare/oriflamms-convert-mss-dates-oriflammsxml.xsl
      • imagesDirectory : indiquer le chemin vers le dossier d'images mss-dates
    • cliquer sur “Exécution”
  • le projet Oriflamms1) résultant correspond au dossier mss-dates situé à côté du document source mss-dates.xml

On peut répéter l'opération de lancement de la macro TEI2Project pour créer le projet Oriflamms du corpus “qgraal_cm” :

  • document : qgraal_cm.xml
  • feuille XSLT : [userDir]/TXM/scripts/macro/org/txm/macro/oriflamms/prepare/oriflamms-convert-graalc-oriflammsxml.xsl
  • dossier d'images : graal

Enfin on peut ouvrir les projets avec le logiciel Oriflamms pour confirmer le bon formatage.

Transformation d'un projet Oriflamms pour importation dans TXM

  • Dans TXM, ouvrir la Vue Macro
    • Menu Affichage –> Vues –> Macro
    • Un onglet Macro s'ouvre au-dessous de la liste des corpus
  • Si aucune macro ne s'affiche dans l'onglet, cliquer sur le bouton “Rafraichir”
  • Dans l'onglet, double-cliquer sur “oriflamms”, puis “prepare”, puis “Project2XTZ” pour lancer son exécution
    • Renseigner son paramètre :
      • projectDir : indiquer le dossier du projet Oriflamms à traiter mss-dates
    • cliquer sur “Exécution”
  • le résultat est enregistré dans un sous-dossier mss-dates/txm
  • ses sous-dossiers peuvent être utilisés comme dossier source pour le module d'import XTZ+CSV de TXM 0.7.8 (voir étape suivante)

On peut répéter l'opération de transformation pour le projet “qgraal_cm” :

  • dossier du projet Oriflamms à traiter qgraal_cm

Importation dans TXM d'un corpus tokenisé par mot

  • Réglage du dossier images
    • Éditer le fichier mss-dates/txm/mss-dates-w/xsl/4-edition/1-facsimile-pager.xsl
      • Glose :
        • mss-dates est le dossier projet Oriflamms
        • txm/mss-dates-w est le dossier source tokenisé par mot préparé pour TXM
        • xsl/4-edition est le répertoire de feuilles XSLT de création des pages d'édition
        • 1-facsimile-pager.xsl est la feuille spécialisée dans la gestion des images de facsimilés
      • À la ligne 58, remplacer la valeur du paramètre 'image-directory' (située entre les balises <xsl:param name=“image-directory”> et </xsl:param>) par le chemin vers le dossier mss-dates contenant les images à utiliser dans l'édition synoptique
      • Enregistrer le fichier 1-facsimile-pager.xsl
  • Dans TXM, lancer la commande du menu 'Fichier / Importer / XML-XTZ + CSV'
  • Cliquer sur “Sélectionner le répertoire des sources”
  • Indiquer le chemin du dossier mss-dates/txm/mss-dates-w
  • Si la police "Junicode" n'est pas installée, cliquer sur l'onglet “Police d'affichage” et sélectionner une autre police permettant d'afficher les caractères médiévaux.
  • Cliquer sur “Lancer l'import du corpus”
  • Une fois l'import terminé, le corpus MSSDATESW apparait dans la vue Corpus

On peut répéter l'opération pour le corpus “qgraal_cm” :

  • fichier à éditer : qgraal_cm/txm/qgraal_cm-w/xsl/4-edition/1-facsimile-pager.xsl
    • chemin vers répertoire d'images : graal
  • dossier source : qgraal_cm/txm/qgraal_cm-w

Vérification du corpus importé

  • Sur le corpus MSSDATESW
  • Vérification du nombre de mots :
    • clic gauche sur le nom du corpus dans la vue Corpus –> Le message “MSSDATESW, T= 14809” s'affiche en bas à gauche de la fenêtre TXM
  • Vérification du lexique :
    • clic droit sur le nom du corpus, puis sélection de la commande Lexique dans le menu contextuel –> le lexique du texte s'affiche
    • le “et tironien” (“7”) s'affiche à la 12e position avec la fréquence 80
  • Vérification de l'édition synoptique :
    • double-clic sur le “et tironien” –> une concordance s'affiche
    • double-clic sur la 7e ligne de la concordance :
      gl̃am deo uoluit iubente declinare iste deo asꝑa “7” dura disponente se studuit ad grauiora
      –> la page de l'édition synoptique contenant l'occurrence du et tironien s'affiche avec à gauche la transcription, où l'occurrence du et tironien est mise en évidence, et à droite l'image du manuscrit correspondante
    • navigation dans l'image :
      • la molette de la souris permet de zoomer
      • le appuyer-glisser avec le bouton gauche de la souris permet de translater l'image
  • Vérification des propriétés de mots :
    • clic droit sur le nom du corpus, puis sélection de la commande Index
    • dans la fenêtre de l'Index, clic gauche sur le bouton Editer, puis double-clic sur les propriétés “letters-all”, “letters-alignable” et “expan” qui passent du volet gauche au volet droit
    • clic sur “OK”
    • saisie de la requête [], puis clic sur “Chercher”
    • la ligne 7 affiche : ĩ_in_i_i(n) avec la fréquence 91
1)
Un fichier projet Oriflamms correspond à ce dossier compressé dans une archive ZIP avec une extension '.oriflamms'
public/upr_irht_oriflamms/recette_v1.txt · Dernière modification: 2016/02/07 15:37 par alexei.lavrentev@ens-lyon.fr