Outils pour utilisateurs

Outils du site


public:upr_irht_oriflamms:tuto_3

Tutoriels TXM pour le projet Oriflamms V3

Création d'un projet Oriflamms

Installation de TXM

  • Installer une mise à jour 0.7.8 Alpha Oriflamms :
    • télécharger l'archive ...
    • décompresser le contenu de l'archive
    • dans TXM, utiliser le menu Fichier / Ajouter une extension tierce
    • Cliquer sur Ajouter…
    • Cliquer sur Local
    • Sélectionner le dossier “repository” créé lors de la décompression de l'archive
    • Décocher la case “Grouper par catégorie”
    • Sélectionner tout et suivre les instructions de l'assistant
  • Installer le paquet de macros Oriflamms
    • télécharger l'archive ...
    • décompresser le contenu de l'archive
    • copier le dossier “oriflamms” dans $USERDIR/TXM/scripts/macro/org/txm/macro

Lancement de l'outil de création d'un projet Oriflamms

  • Dans TXM, ouvrir la Vue Macro
    • Menu Affichage –> Vues –> Macro
    • Un onglet Macro s'ouvre au-dessous de la liste des corpus
  • Si aucune macro ne s'affiche dans l'onglet, cliquer sur le bouton “Rafraichir”
  • Dans l'onglet, double-cliquer sur “oriflamms”, puis “prepare”, puis “TEI2Project”
    • indiquer le document TEI à traiter,
    • indiquer la feuille XSLT de pré-traitement (optionnelle, mais presque toujours indispensable)
    • indiquer le chemin vers le dossier d'images (optionnel)
    • cocher la case createArchive pour créer une archive (corpus.oriflamms) au lieu d'un répertoire
    • cliquer sur “Exécution”
    • le résultat est enregistré à côté du document TEI source

Préparation à l'importation dans TXM

  • Dans TXM, ouvrir la Vue Macro
    • Menu Affichage –> Vues –> Macro
    • Un onglet Macro s'ouvre au-dessous de la liste des corpus
  • Si aucune macro ne s'affiche dans l'onglet, cliquer sur le bouton “Rafraichir”
  • Dans l'onglet, double-cliquer sur “oriflamms”, puis “prepare”, puis “Project2XTZ”
    • indiquer le dossier d'un projet Oriflamms à traiter
    • cliquer sur “Exécution”
    • le résultat est enregistré dans un dossier [nom-du-projet]_txm à côté du dossier du projet Oriflamms traité

Importation dans TXM

Importation d'un corpus tokenisé par mot

  • Dans un navigateur système, ouvrir le dossier de sources [nom-du-projet]/txm/[nom-du-projet]-w produit par la macro Project2XTZ
  • Descendre dans le sous-dossier xsl/4-edition et ouvrir le fichier 1-facsimile-pager.xsl
  • À la ligne 58, remplacer la valeur du paramètre image-directory (située entre les balises <xsl:param name=“image-directory”> et </xsl:param>) par le chemin du dossier contenant les images à utiliser dans l'édition synoptique
  • Enregistrer le fichier 1-facsimile-pager.xsl
  • Dans TXM, cliquer sur Fichier / Importer / XML-XTZ + CSV
  • Cliquer sur “Sélectionner le répertoire des sources”
  • Indiquer le chemin du dossier [nom-du-projet]/txm/[nom-du-projet]-w
  • Si la police "Junicode" n'est pas installée, cliquer sur l'onglet “Police d'affichage” et sélectionner une autre police permettant d'afficher les caractèrs médiévaux.
  • Cliquer sur “Lancer l'import du corpus”
  • Une fois l'import terminé, le corpus apparait dans la vue Corpus

Vérification du corpus

  • Sur le corpus MSSDATESW
    • clic gauche sur le nom du corpus dans la vue Corpus –> Le message “MSSDATESW, T= 14809” s'affiche en bas à gauche de la fenêtre TXM
    • clic droit sur le nom du corpus, puis sélection de la commande Lexique dans le menu contextuel –> le lexique du texte s'affiche
    • le “et tironien” (“7”) s'affiche à la 12e position avec la fréquence 80
    • double-clic sur la ligne du “et tironien” –> une concordance s'affiche
    • double-clic sur la 7e ligne de la concordance –> une page de transcription s'affiche où l'occurrence du et tironien est surlignée, l'image du manuscrit affichée à droite correspond à la transcription
    • clic droit sur le nom du corpus, puis sélection de la commande Index
    • clic gauche sur le bouton Editer, puis double-clic sur les propriétés “letters-all”, “letters-alignable” et “expan” qui passent du volet gauche au volet droit
    • clic sur “OK”
    • saisie de la requête [], puis clic sur “Chercher”
    • la ligne 7 affiche : ĩ_in_i_i(n)

Importation d'un corpus tokenisé par caractère

  • Dans TXM, cliquer sur Fichier / Importer / XML-XTZ + CSV
  • Cliquer sur “Sélectionner le répertoire des sources”
  • Indiquer le chemin du dossier [nom-du-projet]_txm/[nom-du-projet]C
  • Cliquer sur “Lancer l'import du corpus”
  • Une fois l'import terminé, le corpus apparait dans la vue Corpus

Analyse des abréviations par ligne / page / colonne

cf. recette 3

  • Dans TXM, ouvrir la Vue Macro
    • Menu Affichage –> Vues –> Macro
    • Un onglet Macro s'ouvre au-dessous de la liste des corpus
  • Si aucune macro ne s'affiche dans l'onglet, cliquer sur le bouton “Rafraichir”
  • Sélectionner un corpus tokenisé par mot (clic gauche dans la Vue Corpus)
  • Dans l'onglet Macro, double-cliquer sur “oriflamms”, puis “analyse”, puis “AbbreviationsAndLines”
    • spécifier le chemin et le nom du fichier (.tsv) dans lequel les résultats seront enregistrés
    • indiquer le nombre de mots de début de ligne (dist_start)
    • indiquer le nombre de mots de fin de ligne (dist_end)
    • cliquer sur “Exécution”
  • le résultat est enregistré dans le fichier indiqué dans la fenêtre de paramétrage

Analyse des abréviations par entités sémantiques

cf. recette 3

  • Dans TXM, ouvrir la Vue Macro
    • Menu Affichage –> Vues –> Macro
    • Un onglet Macro s'ouvre au-dessous de la liste des corpus
  • Si aucune macro ne s'affiche dans l'onglet, cliquer sur le bouton “Rafraichir”
  • Sélectionner un corpus tokenisé par mot (clic gauche dans la Vue Corpus)
  • Dans l'onglet Macro, double-cliquer sur “oriflamms”, puis “analyse”, puis “AbbreviationsAndSemantic”
    • spécifier le chemin et le nom du fichier (.tsv) dans lequel les résultats seront enregistrés
    • sélectionner dans la liste les entités que l'on veut sonder
    • cliquer sur “Exécution”
  • le résultat est enregistré dans le fichier indiqué dans la fenêtre de paramétrage
public/upr_irht_oriflamms/tuto_3.txt · Dernière modification: 2016/02/12 15:42 par matthieu.decorde@ens-lyon.fr