Recette de l'étape 1 de la chaîne éditoriale intégrant TXM et Métopes

Déploiement de la chaîne éditoriale Métopes

Logiciels

  • Installer XML Mind XML Editor : http://www.xmlmind.com/xmleditor/download.shtml
  • Installer Microsoft Word
    • Versions recommandées :
      • Mac : 2008, 2011
      • PC : 2010, 2013, 2016
  • Installer OpenOffice 4 : http://www.openoffice.org/fr/
    • Ouvrir le programme une première fois et renseigner les données utilisateurs
  • Installer InDesign (version CS4 à CC)
    • Ouvrir le programme une première fois pour permettre à l'application la création de répertoires essentiels
  • Installer les extensions

Manuel d'installation

Tutoriel d'installation Metopes pour Linux

Fichiers d'installation

Installation de TXM

Création du dossier de travail

Afin de permettre la bonne utilisation du la chaîne éditoriale Métopes il convient de travailler avec un dossier normalisé prenant la forme suivante :

  • Nom_du_Dossier (sans espaces ni accents)
    • icono (contient l'iconographie)
      • br
      • mr
      • hr
      • cover.jpg
    • INDD (contient les fichiers .indd)
    • XML (contient les fichiers XML-TEI post TXM)
    • XML_import (contient les fichiers XML sources à importer dans TXM)
    • originaux (contient les manuscrits originaux)
    • styles (contient les manuscrits stylés)

Attention : les noms de fichiers ne doivent comporter ni espaces, ni accents et ne doivent pas commencer par un chiffre.

Télécharger le dossier de test

Import de corpus encodés selon les critères de Métopes

Ajouté AL :

  • Ouvrir le document test_metopes.doc avec OpenOffice 4
    • Ce document contient des titres, des styles de paragraphes, des styles de caractères de la feuille de style Metopes
  • Exporter en XML-TEI avec le filtre XML-TEI Unité éditoriale, enregister dans un dossier nommé “testmetopes”
  • Utiliser le module d'import XTZ de TXM avec les feuilles de styles XSL adaptées.
    • Pour importer un corpus dans TXM via le module d'import XTZ+CSV aller dans le menu “Fichier” puis le sous-menu “Import” et cliquer sur “Module XTZ+CSV”.
    • Une fenêtre de configuration s'affiche. Il faut sélectionner le répertoire contenant les fichiers XML du corpus (corpustestmetopes).
    • Ce même répertoire doit contenir un sous-répertoire où doivent se trouver les XSL nécessaires au résultat souhaité. ⇒ Placer les XSL du dossier “XSL pour l'import XTZ” dans le sous dossier “xsl” du dossier “corpustestmetopes” avec le fichier XML créé lors de l'export OpenOffice.
  • Avant de lancer l'import du corpus il faut prêter attention aux menus déroulants situés en dessous :
    • Editions > nombre de mots par page : 999999
    • Plans textuels > Hors texte à éditer : teiHeader ; Note elements : note
    • Options : décocher “Remove temporary directories”

Macro d'export de fichiers TEI-TXM vers des fichiers compatibles Métopes

  • Placer les XSL du dossier “XSL TXM to Métopes” dans le dossier XSL du dossier TXM de l'utilisateur.
  • Placer les scripts Groovy du dossier “Scripts Groovy” dans le dossier “Macro” du dossier TXM de l'utilisateur.
  • Afficher le menu “macro” dans TXM.
    • Pour ouvrir le menu macro aller dans le menu “Affichage”, puis le sous-menu “Vue” de TXM et cliquer sur “Macro”.
    • Sélectionner le corpus souhaité et lancer la macro correponsant aux fichiers d'entrée (XML-TEI P5 venant d'Oxgarage ou XML-TEI Métopes créé avec le filtre d'export OpenOffice) qui se trouve dans le dossier Create_Metopes avec un double clic.
    • Une fois l'opération achevée un dossier Métopes se crée dans le dossier corpora et contient les fichiers XML-TEI compatibles Métopes.

Téléchargement des scripts

Import dans InDesign

Import d'unité éditoriale

  • Ouvrir InDesign
  • Afficher la fenêtre des scripts (menu “Fenêtre” ⇒ “Utilitaires”)
  • Utiliser le script d'import import_UE.jsx
  • Sélectionner le fichier XML à importer et la maquette souhaitée

Import de volume

  • Ouvrir InDesign
  • Afficher la fenêtre des scripts (menu “Fenêtre” ⇒ “Utilitaires”)
  • Utiliser le script d'import import_vol.jsx
  • Sélectionner le fichier XML maître à importer et la ou les maquette(s) souhaitée(s)

Import dans MaX

public/usr_mrsh/recette_v1.txt · Dernière modification: 2018/05/16 14:22 par alexei.lavrentev@ens-lyon.fr